Microsoft 365 Problème formule

Paskl

XLDnaute Nouveau
Bonsoir à tous,
Je reviens vers vous car j'ai un souci avec mon fichier excel.
Dans ce tableau, j'ai des nombre (en bleu) et du texte dans les cellules.
Dans la colonne F, le résultat devrais être l'entête de colonne ou se trouve la dernière cellule avec des nombres mais ça ne marche pas tout le temps .
Exemple : Ligne 17, 36 et 45
Pouvez vous m'aider SVP ?
Merci.
Paskl
 

Pièces jointes

  • SML .xlsx
    39.5 KB · Affichages: 10

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Paski,
Vous utilisez cette formule :
VB:
=SI(G40<>0;DECALER($A$1;;MAX(SI(I10:U10<> ""; COLONNE(I10:U10)))-1);"")
Donc si I10:U10 est non vide, hors une lettre suffit pour que ce soit non vide.
Essayez :
Code:
=SI(G10<>0;DECALER($A$1;;MAX(SI(ESTNUM(I10:U10); COLONNE(I10:U10)))-1);"")
Là, je teste si le contenu est numérique, donc les chaines de caractères sont ignorées.
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Par exemple, sur la ligne 36, je devrais avoir 362 et sur la ligne 17 je devrais avoir 364
Vous avez ouvert ma PJ ?

1669709973695.png


1669709941863.png
 

Discussions similaires

Réponses
12
Affichages
212

Statistiques des forums

Discussions
303 823
Messages
2 014 450
Membres
219 929
dernier inscrit
Driceros