XL 2019 Power Query - comparer "cellule" ligne paire avec ligne impaire

Flx1er

XLDnaute Junior
Bonjour,
Je désire comparer le contenu d'une cellule d'une ligne paire avec ligne impaire.
Sur la ColC se trouve 2 valeurs "A" et "H", je voudrais identifier sur la colonne "Site" ce qui est commun aux 2 sites ou uniquement chaque site.
En utilisant les formules Excel pas de soucis :
Code:
=SI(E2=1;
    SI(ET(C2="H";C3="H");"H";
        SI(ET(C2="A";C3="A");"A";
            SI(C2<>C3;"C";
            "Oups")));
F1)

Je souhaiterais migrer sous Power Query, mais je n'arrive pas à comparer le contenu d'une cellule d'une paire avec une cellule d'une ligne impaire.
Je vous remercie pour votre aide.

Cordialement,
 

Pièces jointes

  • PQ - Comparer cellule ligne paire avec impaire .xlsx
    10.4 KB · Affichages: 7
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je n'y connais pas grand chose à Power Query mais en consultant le net j'ai trouvé ce lien

En l'appliquant, cela semble donner le résultat attendu.

JHA
 

Pièces jointes

  • PQ - Comparer cellule ligne paire avec impaire .xlsx
    21.8 KB · Affichages: 5

Hasco

XLDnaute Barbatruc
Bonjour,
Bonjour @JHA :)

Voici une solution par regroupement (sur colonne idr) power-query, parmi d'autres possibles. Je choisis souvent celle-ci car plus rapides sur de grands volumes de données.

Vous verrez que je pars des colonnes 'ColC' et 'ColD' uniquement, que la requêtes les insères elle-même, mais bien-sûr on peut partir de votre tableau complet.

Cordialement
 

Pièces jointes

  • PQ - Comparer cellule ligne paire avec impaire .xlsx
    22.5 KB · Affichages: 14

Discussions similaires

Statistiques des forums

Discussions
302 321
Messages
2 002 553
Membres
215 650
dernier inscrit
xhunkukai