optimiser le code suite avec le fichier

  • Initiateur de la discussion philest
  • Date de début
P

philest

Guest
j'ai oublié le fichier
le voici !

philest [file name=moyenne_20060616214454.zip size=21518]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/moyenne_20060616214454.zip[/file]
 

Pièces jointes

  • moyenne_20060616214454.zip
    21 KB · Affichages: 13

ChTi160

XLDnaute Barbatruc
Salut philest
bonsoir le Forum
en pièce jointe ma version,si problème n'hésite pas [file name=moyenneV2.zip size=23917]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/moyenneV2.zip[/file]
 

Pièces jointes

  • moyenneV2.zip
    23.4 KB · Affichages: 17
L

laM

Guest
Bonjour à tous

On peut obtenir le même résultat par formule :
{=MOYENNE(SI(ARRONDI($A$2:$A$332;0)=D2;$C$2:$C$332))}

- Formule matricielle à valider en pressant sur Ctrl+Maj+Entrée
- Puis à recopier vers le bas

Remarque :
289,536
289,876 Apparaissent comme 290
290,557
290,897 Apparaissent comme 291

En tronquant la version arrondie ne risque t'il pas d'y avoir une erreur dans vos calculs ?

290,216 221,107 2,21107
290,557 227,582 2,27582
290,897 217,927 2,17927
Moyenne des nombres dont la partie entière est 290 :
2,22205333

Ce qui est différent du calcul actuel :
289,536 225,962 2,25962
289,876 221,412 2,21412
290,216 221,107 2,21107
Moyenne des nombres dont la partie entière ARRONDIE est 290 :
2,22827

Au revoir, à bientôt

P.S. J'avais bien un fichier à vous joindre mais vraisemblablement un visiteur ne peut plus le faire.
 

Discussions similaires

Réponses
7
Affichages
473
Réponses
5
Affichages
185