Nbre de valeurs différentes

andré

XLDnaute Barbatruc
Salut à vous tous,

Je crois que la maladie d'Al... gagne du terrain.

Je ne parviens plus à me souvenir de la formule permettant de compter dans une plage le nombre d'occurences (valeurs alphabétiques différentes).

A espérer que ce ne soit pas du matriciel, car je dois l'incrémenter.

Vous devrez vous y habituer, je crains fort que vous ayez à l'avenir de plus en plus de ces questions idiotes de ma part (lol).

Je suis peut-être en manque, bon ... ok ... je prends mon remède miracle.

Â+
 

Olivier_HTP

XLDnaute Occasionnel
Bonjour André, le Forum,

Pour calculer le nombre total d'occurrences d'une chaîne dans une zone :

{=(SOMME(NBCAR(ZoneDonnées))-SOMME(NBCAR(SUBSTITUE(ZoneDonnées;Texte;' '))))/NBCAR(Texte)}

Cette formule respecte les majuscules et les minuscules.

Elle est matricielle, désolé !

Bon courage.

Olivier_HTP

Message édité par: Olivier_HTP, à: 29/08/2005 17:04
 

andré

XLDnaute Barbatruc
Salut Olivier,

Je ne crois pas que ce soit cela.

Suppose une liste de fatures, avec les noms des clients.
Combien il y a-t-il de clients différents ?

Par colonne supplémentaire, c'est pas difficile.
Mais par une seule formule, en direct ?

Â+
 

JeanMarie

XLDnaute Barbatruc
Bonjour André

Pour te rafraîchir la mémoire, comme la Duvel sait te rafraîchir le gosier

=SOMME(1/NB.SI(A1:A100;A1:A100))
ou
dans le cas d'une plage contenant des cellules vides
=SOMME(SI(ESTVIDE(A1:A100);0;1/NB.SI(A1:A100;A1:A100)))
cette formule est à valider par Ctrl+Shift+Entrer

@+Jean-Marie

Message édité par: JeanMarie, à: 29/08/2005 18:00
 

MichelXld

XLDnaute Barbatruc
bonjour André , bonjour Olivier

tu peux essayer

Compter le nombre de valeurs différentes dans la plage A1:A10
=SOMMEPROD(1/NB.SI(A1:A10;A1:A10))

Une autres solution de Monique , dans le cas ou il y aurait des cellules vides dans la plage :
=SOMMEPROD(SI(A1:A10<>'';1/NB.SI(A1:A10;A1:A10)))


bonne soiree
MichelXld
 

Olivier_HTP

XLDnaute Occasionnel
Bonsoir Michel, Jean-Marie, re André,

décidément, plus ça va et plus je me dis que SOMMEPROD, bien maîtrisé, sert à une multitude de choses !

Je suis impressionné, et je retourne à mes études que je n'aurais pas dû quitter.

Bonne soirée à tous.

Olivier_HTP
 

andré

XLDnaute Barbatruc
Salut à vous,

Quel concert, avec de plus Monique comme chef d'orchestre, un petit SOMMEPROD() au programme, et une possibilité d'incrémenter comme rafraichissement à l'entr'acte !

Mais bien sur, cela va sans dire, mais c'est quand même beaucoup plus facile après que vous l'ayez dit.
Où avais-je donc la mémoire ?
Peut-être encore au 10 Downing Street (cfr : le retour de Zorro, alias jmps !).

Bonne soirée à vous.
Â+
 

Membres actuellement en ligne

Statistiques des forums

Discussions
299 832
Messages
1 979 414
Membres
206 721
dernier inscrit
Sud catering