XL 2019 Masquer #N/A, FAUX, NON, etc...

Bonjour,
J'ai créé une formule avec 2 critères mais je n'arrive pas à les faire fonctionner ensemble !
Le 1e critère est RECHERCHEV à partir d'une liste déroulante sur une Feuille 2
Le 2e critère est ESTERREUR pour masquer les #N/A, FAUX, NON, issus du 1e critère. La formule fonctionne bien quand la recherche V aboutit à rien.
En revanche, elle ne fonctionne pas quand la recherche V doit aboutir à une réponse positive.
La formule que j'ai mise est la suivante : =SI(ESTERREUR(RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX));"-")
J'ai loupé un truc mais je ne sais pas quoi !
Merci d'avance à la communauté pour son aide.
 
Solution
Bonjour
Sans fichier exemple je pense que tu confonds deux formules :
Avec SI(ESTERREUR
VB:
=SI(ESTERREUR(RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX));"-";RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX))
Avec SIERREUR
Code:
=SIERREUR(RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX);"-")

Cordialement

Efgé

XLDnaute Barbatruc
Bonjour
Sans fichier exemple je pense que tu confonds deux formules :
Avec SI(ESTERREUR
VB:
=SI(ESTERREUR(RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX));"-";RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX))
Avec SIERREUR
Code:
=SIERREUR(RECHERCHEV($AJ3;'liste déroulante'!$J$2:$Y$20;2;FAUX);"-")

Cordialement
 

Discussions similaires

Statistiques des forums

Discussions
302 098
Messages
2 000 373
Membres
214 829
dernier inscrit
Pierroth29