liste déroulante

calou

XLDnaute Occasionnel
bonsoir le forum,
est-il possible de faire une liste de données (déroulante) dans une cellule de telle sorte que lorsque l'on choisit un produit, dans la cellule à côté apparaisse un tarif. J'ajoute que j'utilise excel 2007.
Je joins un fichier. D'avance merci et bonne soirée à tous.
Calou
 

Pièces jointes

  • essai du 14012014.zip
    9.6 KB · Affichages: 30

Calvus

XLDnaute Barbatruc
Re : liste déroulante

Bonsoir,

Nom définition B4:B10 = Légumes
En B13, Données Validation Liste = Légumes

En C13 le code suivant
Code:
=INDEX($B$4:$C$10;EQUIV($B$13;Légumes;0);2)

Te permet d'avoir le prix équivalent pour chaque produit.
Voir fichier joint.

A+
 

Pièces jointes

  • calou.xlsx
    10.2 KB · Affichages: 30

calou

XLDnaute Occasionnel
Re : liste déroulante

Bonjour à tous les 3, bonjour le forum,
tout d'abord merci et j'ai essayé vos différentes solutions et ça fonctionne mais est ce que je peux avoir ma liste qui fournit ma liste déroulante (dans mon exemple la liste des légumes) dans une autre feuille et si oui comment dois je faire?
Merci et bonne journée.
Calou
 

Calvus

XLDnaute Barbatruc
Re : liste déroulante

Bonjour,

Oui, tout simplement en suivant mon exemple. Le champ est nommé, donc tu te mets dans une autre feuille, tu choisis ta cellule, et tu suis la procédure indiquée dans le post #2. Pour les prix, la même formule (ou Recherchev si tu préfères celle-là ) et en mettant

=INDEX(nomdelafeuille!$B$4:$C$10;EQUIV($B$13;Légumes;0);2)

Bonne journée
 

excfl

XLDnaute Barbatruc
Re : liste déroulante

Re,

est ce que je peux avoir ma liste qui fournit ma liste déroulante (dans mon exemple la liste des légumes) dans une autre feuille

=RECHERCHEV(B4;fichier;2;FAUX)

excfl
 

Pièces jointes

  • Liste déroulante.xlsx
    10.1 KB · Affichages: 25
  • Liste déroulante.xlsx
    10.1 KB · Affichages: 28
  • Liste déroulante.xlsx
    10.1 KB · Affichages: 28
Dernière édition:

calou

XLDnaute Occasionnel
Re : liste déroulante

rebonjour à tous,
merci pour vos explications. J'ai fait un essai ça a l'air de fonctionner. Je n'ai plus qu'à essayer ce week-end sur l'ordi du boulot. Si j'ai des soucis je reviendrai vers vous. Encore merci à vous 3 et bonne soirée à tous.
Calou
 

Discussions similaires

Statistiques des forums

Discussions
299 847
Messages
1 979 562
Membres
206 773
dernier inscrit
becaye80