Microsoft 365 Ligne suivante si vide

mllemoon

XLDnaute Nouveau
Bonjour, j'ai une liste avec quelques colonnes que je veux recopier dans une autre feuille si la bonne colonne contient un "x".
Dans cette autre feuille, je ne veux que voir les options choisies.
J'ai mis un fichier car je suis certainement pas claire !

Merci Karine
 

Pièces jointes

  • Ligne_suivante.xls
    84.5 KB · Affichages: 8

JHA

XLDnaute Barbatruc
Bonjour à tous,

La formule est assez compliquée à mettre en œuvre.
VB:
=SIERREUR(INDEX(All!A$2:A$12;PETITE.VALEUR(SI(DECALER(All!$C$1;1;EQUIV($G$1;All!$D$1:$F$1;0);NBVAL(All!$A$2:$A$12))="x";LIGNE(DECALER(All!$C$1;1;EQUIV($G$1;All!$D$1:$F$1;0);NBVAL(All!$A$2:$A$12)))-1);LIGNE(1:1)));"")
C'est une formule matricielle il faut donc la valider avec les 3 touches Ctrl+Maj+Entrée.
Si la validation est correcte, des accolades vont se mettre de chaque côté de la formule.

Quels sont tes soucis avec cette formule, peux-tu joindre un extrait de quelques lignes de ton fichier?

JHA
 

mllemoon

XLDnaute Nouveau
Merci beaucoup.

Dans le fichier, pourriez-vous mettre la formule dans les pages relatives à Sable? La page "Options sable" représente toutes les options Sable et la page "Option Sable Choix" représente les éléments choisis seulement.

J'ai mis un exemple de ce que je recherche comme résultat dans les page Options Mer et Options Mer Choix.
(voir nouveau fichier joint Ligne_suivante Rev2.xls)

Merci
Karine
 

Pièces jointes

  • Ligne_suivante Rev2.xls
    104 KB · Affichages: 2

Discussions similaires

  • Question
XL 2019 vba
Réponses
3
Affichages
119

Statistiques des forums

Discussions
299 878
Messages
1 979 752
Membres
206 858
dernier inscrit
M.nahali