LA FONCTION "SI"

J

Jef

Guest
Je salue mon ou mes sauveurs...

Je fais appel à vos dons en la matière

Il faut que je fasse une formule pour que lorsque dans la case A1 j'inscris un chiffre, apparaissent en case A2 un autre chiffre.

Jusque là c'est pas compliqué.

Là où ça se corse c'est ici

exemple:

Si A1 est >=300 MAIS 600 mais 900 mais 1201 mais <1499 en A2 il faut 1.86

Y-a-t-il une formule qui marcherait. Peut être dois-je utiliser la fonctio n ET ou OU.

Merci

Jef
 
L

La formule est erronée

Guest
Donc je la recommence

Si A1 est supérieur ou égal à 300 mais inférieur à599 il faut qu'en A2 apparaisse 2.01

Si A1 est supérieur à 600 mais inférieur à899 il faut qu'en A2 apparaisse 1.89

Si A1 est supérieur à 900 mais inférieur à1200 il faut qu'en A2 apparaisse 1.87

Si A1 est supérieur à 1201 mais inférieur à1499 il faut qu'en A2 apparaisse 1.86

Voilà qui est rectifié suite au bug du message du dessus

Merci

Jef
 

SergiO

XLDnaute Accro
Jef,

Voici une solution :

=SI(A1>=1500;'';SI(A1>=1200;1.86;SI(A1>=900;1.87;SI(A1>=600;1.89;SI(A1>=300;2.01;'')))))

Si A1 est = 1500; ça renvoie une cellule vide.

Si tu veux renvoyer autre chose, insère-le entre les '' correspondants.

Bon courage.
 

SergiO

XLDnaute Accro
Jef,

Voici une solution :

=SI(A1>=1500;'';SI(A1>=1200;1.86;SI(A1>=900;1.87;SI(A1>=600;1.89;SI(A1>=300;2.01;'')))))

Si A1 est = 1500; ça renvoie une cellule vide.

Si tu veux renvoyer autre chose, insère-le entre les '' correspondants.

Bon courage.
 

Gael

XLDnaute Barbatruc
Bonsoir Jef, bonsoir Sergio,

Si ce n'est pas trop tard, une autre solution avec Choisir/Equiv que je trouve plus pratique que des SI imbriqués et plus clair si l'on doit faire des changements:

=CHOISIR(EQUIV(A1;{0;300;600;900;1200;1500};1);'';2,01;1,89;1,87;1,86;'')

@+

Gael
 

Discussions similaires