index+petit.valeur ligne (horizontale)

Antibios

XLDnaute Nouveau
Bonjour,

J'essai de créer une liste horizontale sans trous avec l'indexage d'une ligne avec trous.
J'arrive à faire cette manipulation verticalement en combinant index+petit.valeur, mais impossible pour moi de comprendre comment faire horizontalement.

Le code verticale :
Code:
=SIERREUR(INDEX($A$2:$A$11;PETITE.VALEUR(SI($A$2:$A$11="";"";LIGNE($1:$10));LIGNE(1:1)));"")

Les codes horizontaux (qui ne fonctionnent pas) :
Code:
=SIERREUR(INDEX($D$2:$K$2;PETITE.VALEUR(SI($D$2:$K$2="";LIGNE(2:2)-2;"");COLONNE($A:$A)));"")
=SIERREUR(INDEX($D$2:$K$2;PETITE.VALEUR(SI($D$2:$K$2="";LIGNE(2:2);"");COLONNE()-3)-1);"")==SIERREUR(INDEX($D$2:$K$2;PETITE.VALEUR(SI($D$2:$K$2="";"";LIGNE(1:$8));COLONNE(A:A)));"")
=SIERREUR(PETITE.VALEUR(SI((NBVAL(DECALER($D$2;;;1;COLONNE($D$2:$K$2));$D$2:$K$2)=1)*($D$2:$K$2<>"");$D$2:$K$2;"");COLONNE());"")
=SIERREUR(INDEX($D$2:$K$2;2;PETITE.VALEUR(SI($D$2:$K$2="";"";COLONNE($D:$K));COLONNE(1:1)));"")

Si vous pouvez m'aider a comprendre comment faire. Je pense que j'ai pas bien compris l'histoire des Ligne() et Colonne(). A moins que j'ai rien compris de tout. :eek:

Merci d'avance pour votre aide. :)
 

Pièces jointes

  • Index+pt.val.xlsx
    16.1 KB · Affichages: 34

Antibios

XLDnaute Nouveau
Je reviens sur le sujet,

Est-il possible de combiner plusieurs indexage en 1?

Par exemple :
Code:
{=SIERREUR(INDEX($D$2:$K$2;PETITE.VALEUR(SI($D$2:$K$2<>"";COLONNE($D$2:$K$2)-3);COLONNES($A:A)));"")}
{=SIERREUR(INDEX($D$3:$K$3;PETITE.VALEUR(SI($D$3:$K$3<>"";COLONNE($D$3:$K$3)-3);COLONNES($A:A)));"")}

J'ai essayé çà mais sans résultat.
Code:
=SIERREUR(INDEX($D$2:$K$3;PETITE.VALEUR(SI($D$2:$K$3<>"";COLONNE($D$2:$K$3)-3);COLONNES($A:A)));"")
 

Antibios

XLDnaute Nouveau
Mon fichier en exemple n'est pas en rapport avec ma question.
Mais la base du sujet si. Je peux toujours créer un nouveau post si besoin.

Voici mon exemple qui devrait aider a comprendre ma question précédente
Je reviens sur le sujet,

Est-il possible de combiner plusieurs indexage en 1?

Par exemple :
Code:
{=SIERREUR(INDEX($D$2:$K$2;PETITE.VALEUR(SI($D$2:$K$2<>"";COLONNE($D$2:$K$2)-3);COLONNES($A:A)));"")}
{=SIERREUR(INDEX($D$3:$K$3;PETITE.VALEUR(SI($D$3:$K$3<>"";COLONNE($D$3:$K$3)-3);COLONNES($A:A)));"")}

J'ai essayé çà mais sans résultat.
Code:
=SIERREUR(INDEX($D$2:$K$3;PETITE.VALEUR(SI($D$2:$K$3<>"";COLONNE($D$2:$K$3)-3);COLONNES($A:A)));"")
 

Pièces jointes

  • essai planning (2).xlsm
    42.6 KB · Affichages: 35

Discussions similaires

Statistiques des forums

Discussions
299 850
Messages
1 979 570
Membres
206 780
dernier inscrit
Edwige81