Incrementation cellule sous Condition

manu70

XLDnaute Nouveau
Bonjour tous le monde, bonjour le forum,

Je voudrais incrementer automatiquement une cellule dans un calendrier, j'utilise la formule suivante pour savoir si le jour existe ou pas (année bisextile !!!)

Dans ma cellule D8 j'applique cette formule :

=SI(B8<>'';'Roul-Repos'!A2+AA2;'')

B8 represente le jour du mois (ex 01, pour le 1er janvier)

'Roul-Repos! est la feuille que j'utilise pour lire les roulements de repos a affecter au jour. et je voudrais incrementé la cellule AA2 des que la condition est vrai.

Sachant que le roulement contient 42 jours et que AA2 doit revenir a Zero Si sa valeur doit depassé 41. Quelle est la syntaxe exacte dans cette formule.

J'ai essayé un truc du genre :

=SI(B8<>'';'Roul-Repos'!A2+AA2:AA2=AA2+1;'')

Mais EXCEL ne l'accepte pas

Merci d'avance de m'eblouir de vos Lumieres

Ci-joint fichier ZIP

Manu70 [file name=Calendrier_20051104165813.zip size=19635]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Calendrier_20051104165813.zip[/file]
 

Pièces jointes

  • Calendrier_20051104165813.zip
    19.2 KB · Affichages: 27

Monique

Nous a quitté
Repose en paix
Bonjour,

Sans utiliser la valeur de la cellule AA2 (ou bien je n'ai rien compris)
=SI(B8='';'';INDEX(Cycle;MOD(B8-Depart;42)+1))

Cycle est le nom de la plage où tu as tes nb de 1 à 42
Depart est le nom d'une cellule dans laquelle
tu saisis une quelconque des dates où tu veux avoir le 1er nb de la plage 'Cycle'

MOD(B8-Depart;42) te donne le reste de la division par 42 de B8-Depart
INDEX(Cycle;Reste) te renvoie la valeur contenue dans
la 1ère cellule de 'Cycle' si Reste = 1
la 42ème cellule de 'Cycle' si Reste = 42

Dans ton exemple,
si tu veux 7 au 01-01-2005,
tu saisis en cellule 'Depart' soit 01-01-2005, soit 01-01-2005+42, etc
Au 31-12-2005, tu obtiens 35,
au 01-01-2006, tu obtiens 36 sans rien modifier

La colonne 'Repos', je n'ai pas compris.
Tu es en repos tous les jours ou bien c'est un n° d'équipe ?

Si tu cherches sur le forum planning et cycle, tu trouves d'autres exemples, dont celui-ci :
Lien supprimé
[file name=CycleManu.zip size=25384]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CycleManu.zip[/file]
 

Pièces jointes

  • CycleManu.zip
    24.8 KB · Affichages: 45

manu70

XLDnaute Nouveau
Bonjour Monique,

Encore une fois tu es au top !

Je vais essayer de comprendre ta manip, mais en tout cas c'est exactement ce que je voulais faire !

Et non, je ne suis pas en repos tous les jours (malheureusement !!!).

Chaque personne de ma boite a un N° de repos qui lui est propre et ce calendrier sert a savoir quand il peux officielement se reposer...

C'est ça les fonctionnaires !!!!!

Encore un grand merci, faut que je me colle sur les mises en forme conditionnelles.

Manu70
 

Statistiques des forums

Discussions
300 716
Messages
1 986 638
Membres
209 554
dernier inscrit
Khaay