formule trop longue :-(

fifi

XLDnaute Occasionnel
bonsoir,
j'ai un petit problème de formule ;) .

j'aimerai savoir à coté de quel point principale (dont les coordonées sont ci dessus) est un autre point dont je rentre les coordonées.

point X Y
1 0 0
2 0 -104
3 -104 0
4 104 -104
5 -208 0
6 -104 -104
7 104 0
8 0 104
9 0 -208
10 -104 104


est-ce possible? sans avoir trop de SI dans la formule?

merci de votre aide encore une fois
 
L

laM

Guest
Bonjour Fifi

A mon avis, et si j’ai bien compris, vous recherchez la distance la plus courte entre un point fixe et un des points de la liste.
On peut donc calculer les distances avec une formule du genre :
Cellule A2=RACINE((C2-$C$1)^2+(D2-$D$1)^2)
X du point fixe = $C$1
Y du point fixe = $D$1
X du premier point C2
Y du premier point D2
une petite recopie de formule pour les 10 points,
et la fonction =MIN(A2 :A11) devrait donner la distance la plus courte.
Couplé à RECHERCHEV, en supposant que B2 :B11 contiennent le numéro des points
Cellule A1 =RECHERCHEV(MIN(A2:A11);A2:B11;2;FAUX)
A1 donnera le numéro du point le plus proche

Au revoir, à bientôt
P.S. le fichier devrait suivre
[file name=Distance.zip size=6875]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Distance.zip[/file]
 

Pièces jointes

  • Distance.zip
    6.7 KB · Affichages: 21
  • Distance.zip
    6.7 KB · Affichages: 19
  • Distance.zip
    6.7 KB · Affichages: 16

Discussions similaires

Statistiques des forums

Discussions
299 878
Messages
1 979 752
Membres
206 857
dernier inscrit
Pageee