XL 2019 Formule Si avec cellule qui contient un texte spécifique

PMME

XLDnaute Nouveau
Bonjour!
Je souhaite faire une formule avec des SI et OU en fonction de si la cellule contient un texte ou un autre.

Voici ma formule :

=SI(STXT(B1;1;1)="9";"FRAISE";SI(STXT(B1;1;3)="3";"ABRICOT";"LEGUME"))


Si ma cellule commence par un 9 alors FRAISE, Si ma cellule à pour 3eme caractère le chiffre 2 alors ABRICOT sinon LEGUME

Cette formule prends en compte la première condition mais pas la deuxième ;(


Pouvez vous m'aider svp ?


Merci beaucoup!!!
 

Deadpool_CC

XLDnaute Impliqué
Bonsoir,

3ieme caractère = 2 donne abricot ?
tu testes avec "3"
1655315128446.png

et si jamais t'as 912 en B1 ... cela sera toujours des fraises et jamais des abricots malgré le 2 en 3ieme position :)
 

PMME

XLDnaute Nouveau
oui pardon je me suis trompée c'st bien si le 3eme caractère = 3 alors abricot!
=SI(STXT(B1;1;1)="9";"FRAISE";SI(STXT(B1;1;3)="3";"ABRICOT";"LEGUME"))

Si ma cellule commence par un 9 alors FRAISE, Si ma cellule à pour 3eme caractère le chiffre 3 alors ABRICOT sinon LEGUME

Pr le coup je n'ai jms de cellule qui commence par 9 et qui ont pr 3 eme caractère en 3 !
 

soan

XLDnaute Barbatruc
Inactif
Bonsoir PMME, Deadpool,

bienvenue sur le site XLD ! :)

GAUCHE(B1;1) est plus simple que STXT(B1;1;1)

et pour éviter que ça retourne "LEGUME" si B1 est vide :

=SI(B1="";"";SI(GAUCHE(B1;1)="9";"FRAISE";SI(STXT(B1;3;1)="3";"ABRICOT";"LEGUME")))

soan
 

soan

XLDnaute Barbatruc
Inactif
Bonjour PMME (alias PGH), le fil,

je t'ai répondu avec mon post #6 ; si ça te convient, merci de faire ceci :

1) marquer le post #6 comme solution, de cette façon :

Coche.jpg


2) à propos de ton multipost (= cross-posting) :

* de préférence, c'est à éviter ! :( IMPORTANT ! clique sur ce lien bleu :
paragraphe 2.10 de la Charte XLD : tu dois lire le texte sur
fond violet.

* indiquer sur ton autre sujet « Si Ou cellue qui contient un texte spécifique »
du site excel.engalere.com que ta demande a été résolue ici. :)

ci-dessus, clique sur le lien bleu « autre sujet » pour y aller.

soan
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
300 889
Messages
1 988 140
Membres
210 082
dernier inscrit
bernard.dufaure.47@gmail.