fonction MIN-petite valeur en rouge

R

remi lantin

Guest
bonjour, dans une liste chiffre, je voudrais que les 3 plus petites valeurs s`affichent en rouge.Comment procéder?
 
A

andré

Guest
salut rémi,

je résolverai ton problème comme suit :

je suppose que ta liste est triée, autrement que sur les valeurs dont tu veux mettre les trois plus petites en rouge.

tu enregistres une macro reprenant la procédure suivante :
tu tries la colonne des valeurs (par ordre croissant).
les trois plus petites valeurs s'affichent au-dessus, toujours dans les mêmes cellules.
tu mets la police de ces cellules en rouge.
tu remets la police des autres cellules en noir.
tu retries sur la colonne de tri initial.
tu stoppes l'enregistrement de ta macro.

je n'ai pas encore trouvé de formule pouvant le faire automatiquement sans passer par une macro, mais je ne désepère pas.

si ta colonne initiale n'est pas triée, fais le moi savoir, je te dirai commant il faut faire.

andré.
 
C

chris

Guest
Utilises la mise en forme conditionnelle : exemple
si les valeurs sont en colonne A et démarrent en A1 et finissent en A6 cela donne :
=SI(RANG(A1;$A$1:$A$6;1)<4;VRAI;FAUX) à mettre dans formule pour la première cellule.
Puis recopier le format seul sur les cellules A2 à A6 (copier collage spécial format)
(Tu peux mettre $A$1:$A$500 au lieu de $A$1:$A$6 pour éviter une mise à jour à chaque allongrement de ta liste)
Chris
 

Discussions similaires

Statistiques des forums

Discussions
303 720
Messages
2 013 469
Membres
219 628
dernier inscrit
aqwx