encore une histoire de doublons !

dudu

XLDnaute Nouveau
Bonjour à tous,
Bien que ce sujet ai été traité dans tous les sens sur ce forum, je finis par y perdre mon modeste Excel...
J'ai un fichier comprenant entre autre 2 feuilles:
la 1ère nommée "base" recense toutes les personnes (connues par un seul et unique numéro ) qui ont un ou plusieurs enfants et donc peuvent apparaitre sur plusieures lignes ( une par enfant en fait).
la 2ème "recap annuelle" doit reprendre chacune de ses personnes mais qu'une seule fois ( toujours par ce seul numéro) afin qu'y soient regroupés tous les paiements effectués dans l'année pour tous les enfants de chaque personne (cette fonction ayant été occultée pour les besoins de transfert de fichier).
Si vous pouviez m'aider ?
par avance, merci.
 

dudu

XLDnaute Nouveau
Re : encore une histoire de doublons !

avec le fichier ? c'est sans doute mieux ...
Désolé!
 

Pièces jointes

  • Dudu_FonctionsPerso.xls
    46.5 KB · Affichages: 79
  • Dudu_FonctionsPerso.xls
    46.5 KB · Affichages: 81
  • Dudu_FonctionsPerso.xls
    46.5 KB · Affichages: 80
G

Guest

Guest
Re : encore une histoire de doublons !

Re,

Avec un filtre élaboré sans critère et extraction sans doublon

Selectionne une cellule libre le la feuille Recap (sans valeur autour)

Menu Données/filtrer/filtre élaborés et rempli comme dans l'image ci-dessous.



quand tu dis:
doit reprendre chacune de ses personnes

c'est chaque enfant ou chaque agent?
si c'est chaque enfant tu sélectionnes 2 colonnes de plus dans la base (nom et prénom de l'enfant)

A+
 
Dernière modification par un modérateur:

david84

XLDnaute Barbatruc
Re : encore une histoire de doublons !

Bonjour, salut Hasco;)
En partant de ta formule, formule matricielle à placer en A3 de recap annuelle et à valider par crtl, maj et entrée :
=SI(LIGNES($1:1)<=SOMME(SI(base!A$3:A$16<>"";1/NB.SI(base!A$3:A$16;base!A$3:A$16)));INDEX(base!A$3:A$16;EQUIV(MIN(SI(NB.SI(A$2:A2;base!A$3:A$16)=0;SI(base!A$3:A$16<>"";LIGNE(base!A$3:A$16))));SI(NB.SI(A$2:A2;base!A$3:A$16)=0;SI(base!A$3:A$16<>"";LIGNE(base!A$3:A$16)));0));"")

Tirer la formule vers la droite et le bas.

Mais un TCD est également approprié.
A+
 
G

Guest

Guest
Re : encore une histoire de doublons !

Re,

Oui cela peut-être automatisé mais en écrasant les données déja extraites.

Mais avant que de nous lancer là-dedans j'aimerai avoir une vision plus précise de l'objectif final, avec un exemple plus élaboré.

De plus peux-tu préciser ta question:
la 2ème "recap annuelle" doit reprendre chacune de ses personnes mais qu'une seule fois ( toujours par ce seul numéro)

Chaque Agent (Nom et Prénom) ou chaque Agent avec chacun de ses enfants ?

A+
 

Statistiques des forums

Discussions
299 878
Messages
1 979 749
Membres
206 856
dernier inscrit
Proux