dates dégressives (formule ou macro)

Batiscaf

XLDnaute Occasionnel
Bonsoir le forum,

Je reviens vers vous concernant un petit souci que vous pourrez voir
 

Batiscaf

XLDnaute Occasionnel
Oups ! ce n'est pas parti correctement ! :S
Je recommence.


Bonsoir le forum,

Je reviens vers vous concernant un petit souci que vous pourrez voir dans les cellules en jaune du fichier joint.

J'ai en cellule D16 le mois le plus élevé de la colonne F de la base du dessus. Jusque là pas de soucis.
Par contre, à partir de cette date, j'ai besoin de faire une répartition sur les 11 autres mois précédents, hors je ne sais pas comment implémenter les mois des cellules E16 à O16.

Vous pourrez constater que je n'ai pu le faire que manuellement.

Auriez-vous une solution, sous forme de formule ou macro, pour éviter des telles manipulations ?

D'avance merci.

Bat. [file name=Classeur1forum_20051022004142.zip size=8399]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur1forum_20051022004142.zip[/file]
 

Pièces jointes

  • Classeur1forum_20051022004142.zip
    8.2 KB · Affichages: 24

Monique

Nous a quitté
Repose en paix
Bonjour,

Le dernier mois :
=DATE(ANNEE(MAX($F$2:$F$12));MOIS(MAX($F$2:$F$12));1)
Le mois précédent :
=DATE(ANNEE(D16);MOIS(D16)-1;1)
C'est du numérique, format mmm-aa

Le SommeProd avec des dates numériques :
=SOMMEPROD(($D$2:$D$12=$B17)*(MOIS($F$2:$F$12)=MOIS(D$16))*(ANNEE($F$2:$F$12)=ANNEE($F$2:$F$12))*$K$2:$K$12)
[file name=DatesBatiscaf.zip size=8491]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/DatesBatiscaf.zip[/file]
 

Pièces jointes

  • DatesBatiscaf.zip
    8.3 KB · Affichages: 25

Batiscaf

XLDnaute Occasionnel
Bonsoir le forum, et peut-être plus Monique dans ce cas.

Je reviens sur ce post car j'arrive maintenant à la fin de ma macro et j'ai un souci dans quelques cas avec la formule sommeprod de Monique m'a proposé.

Vous pourrez voir dans le fichier joint ce qui pose problème.
Lorsque j'ai des soldes de plus de 12 mois, les montants de ces soldes se remettent dans les 12 premiers mois éclatés plutôt que dans la colonne 'antérieur' --> exemples des clients Total SA et Eurodisney.

Si vous pouvez venir à mon secours je vous en serais très reconnaisant.

Cordialement.

Bat.
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Je me suis trompée dans le précédent fichier.

En F8 et toutes les autres cellules :
=SOMMEPROD((base!$D$2:$D$15=$B8)*(MOIS(base!$F$2:$F$15)=MOIS(F$6))*(ANNEE(base!$F$2:$F$15)=ANNEE(F$6));base!$K$2:$K$15)

Ce n'est pas :
(ANNEE(base!$F$2:$F$15)=ANNEE(base!$F$2:$F$15))
C'est :
(ANNEE(base!$F$2:$F$15)=ANNEE(F$6))
 

Discussions similaires

Réponses
4
Affichages
210

Membres actuellement en ligne

Statistiques des forums

Discussions
300 761
Messages
1 987 017
Membres
209 680
dernier inscrit
frobleyy