Microsoft 365 Comptez les chiffres issue d'une plage avec lettre et chiffre

Muzomax59

XLDnaute Nouveau
Bonjour,

J'ai trouvé cette formule sur le forum

https://www.excel-downloads.com/threads/excel-quelques-fonctions-excel.34872/

Additionner les cellules de la plage A1:A10 , alors que chaque premier caractère commençe par une lettre
{=SOMME(DROITE(A1:A10;(NBCAR(A1:A10)-1))*1)}

Sauf qu'elle ne fonctionne plus si une cellule est vide.

Quelqu'un aurait une solution ?

Merci

Max
 

Deadpool_CC

XLDnaute Impliqué
un fichier exemple de ce que tu dois faire ... car il y a peut être plus simple qu'une formule matricielle ;)

sinon essaye avec cette formule
VB:
{=SOMME(SI(ESTVIDE(A1:A10);0;DROITE(A1:A10;(NBCAR(A1:A10)-1))*1))}
 
Dernière édition:

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Muzomax
Essayez :
VB:
=SOMME(SI(A1:A10="";0;DROITE(A1:A10;(NBCAR(A1:A10)-1))*1))
Toujours avec validation Maj+Ctrl+Entrée.

et si par hasard une cellule ne contenait qu'un vide ou juste des lettres :
VB:
=SOMME(SIERREUR((DROITE(A1:A10;(NBCAR(A1:A10)-1))*1);0))
Toujours avec validation Maj+Ctrl+Entrée.
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
302 236
Messages
2 001 684
Membres
215 256
dernier inscrit
Adso