Compter un texte dans une cellule ?

  • Initiateur de la discussion Fanou59
  • Date de début
F

Fanou59

Guest
Bonjour,

Voici ma question :

Je télécharge un compte rendu de forumlaire depuis mon site internet. Dans ce compte rendu j'ai plusieurs textes dans une même cellule... Comment puis je faire pour compter les mots qui m'intéressent seulement ?

Petit exemple: voir fichier joint .

Dans ce fichier, je voudrai compter combien de Rpm, combien de Body Jam etc.... et ce selon les heures ?

Merci pour vos lumières.....

Fanou
 
F

Fanou59

Guest
Bin mince alors ! [file name=exemple_20050823210505.zip size=1816]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/exemple_20050823210505.zip[/file]
 

Pièces jointes

  • exemple_20050823210505.zip
    1.8 KB · Affichages: 21
F

Fanou59

Guest
Hep !! C'est pas la peine j'ai trouvé la formule en cherchant longuement sur le forum....

Désolé !

Pour info et pour ceux que ça intéresse :

=sommeprod(estnum(trouve('letexte';laplage))*1

Par contre je comprend rien à la formule ! :eek: Donc si qqn à 2 minutes pour m'expliquer ...
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Cherche() est peut-être mieux que Trouve() : pas besoin de faire attention aux majuscules minuscules

=CHERCHE('AZ';E5) renvoie #VALEUR! si 'AZ' n'existe pas
=CHERCHE('rpm';E5) donne la position (un n° de position) de 'rpm' dans la cellule
=ESTNUM(CHERCHE('rpm';E5)) renvoie Vrai ou Faux
=ESTNUM(CHERCHE('rpm';E5))*1 renvoie 1 pour Vrai et 0 pour Faux
Mais... ça ne te donne pas le nb de fois

Et SommeProd ne sert à rien, sauf sur plusieurs cellules :
=SOMMEPROD(ESTNUM(CHERCHE('rpm';A5:F5))*1)
te renvoie le nb de cellules contenant 'Rpm' ou 'rpm' ou 'RPM' etc
En gros, sommeprod fait la somme des produits (Vrai*1;Faux*1;Faux*1)

Pour avoir le nb de fois où l'on trouve 'rpm' dans une cellule (en E5 par exemple) :
=(NBCAR(E5)-NBCAR(SUBSTITUE(E5;'Rpm';'')))/NBCAR('Rpm')
 
F

Fanou59

Guest
Bonjour,

oui, mais moi je veux la somme des mots rpm dans la colonne samedi 8 . Et comme dans certaines cellules j'ai plusieurs textes... c'est peut être pour ça que j'utilise sommeprod ? non ?
 

Discussions similaires

Statistiques des forums

Discussions
299 728
Messages
1 978 789
Membres
206 395
dernier inscrit
Bilina