Compter nombre de fois où 2 valeurs entre 2 colonnes sont différentes

Ikito

XLDnaute Occasionnel
Bonjour à tous,

Étant une bille en formule, je viens vers vous.

Le but ici et de compter le nombre de fois ou j'ai des valeurs différentes sur 2 colonnes, voir tableau ci-dessous :


1​
1​
0​
0​
1​
0​
0​
1​

Ligne 1 : 1 et 1, on ne compte pas
Ligne 2 : 0 et 0, on ne compte pas
Ligne 3 : 1 et 0, on compte (1)
Ligne 4 : 0 et 1, on compte (1+1 = 2)

Je ne doute pas que vous allez trouver une solution :)
 
Dernière édition:

Antibios

XLDnaute Nouveau
Bonjour,

Pour aller plus loin dans cette fonction, je recherche la formule qui me permettrait d'additionner les éléments différents de la colonne B.

1​
1​
2​
5
3​
3​
4​
5​
5​
6​
2
7​
7​
8​
6
9​
9​
résultat recherché = 13​

Soit 4 différences , mais que 3 à additionner. J'ai essayé avec des formules combinant sommeprod et nb.si, somme.si.ens et nb.si mais je n'arrive pas au résultat recherché.
Pourriez-vous m'aider svp? 🙏
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Il serait bon à l'avenir de créer une nouvelle demande.

A essayer

VB:
=SOMME(SI(((MOD(LIGNE(B2:B9);2)=0)*$B$2:$B$9)<>((MOD(LIGNE(B1:B8);2)=1)*$B$1:$B$8);B2:B9))
Validation matricielle

JHA
 

Pièces jointes

  • Classeur Antibios.xlsx
    9.4 KB · Affichages: 3

Antibios

XLDnaute Nouveau
Merci pour ton assistance JHA. Je vais créer une nouvelle demande alors.

La formule que tu m'as fournie n'a pas l'air de se comporter comme attendu. On obtient bien le résultat de 13 (sans vraiment comprendre la formule), mais les lignes 1 et 9 ne sont pas prises en compte et si je fais des changements de chiffre cela n'est pas pris en compte.
Comment ta formule fait pour comparer la colonne B à la A?
 

Statistiques des forums

Discussions
299 850
Messages
1 979 570
Membres
206 780
dernier inscrit
Edwige81