Microsoft 365 Compter le nombre de cellule colorié selon une critère date

Abdoul aziz

XLDnaute Junior
Bonjour à Tous quelqu'un pourrait il m'aider

Je souhaite écrire une fonction ou formule qui me compte le nombre de cellule colorié en bleu (FEUIL 1 COLONNE A) et qui prends en compte les dates de la colonne B
EXEMPLE POUR LE MOIS DE JANVIER ; il va me compter le nombre de cellule colorié en bleu et dont les valeurs de la colonne B sont compris entre le 01/01/2022 et le 31/01/2022
ainsi de suite pour le mois de février.

les résultats seront mis dans ma feuil sheet1 (COLONE B)
merci
 

Pièces jointes

  • fi.xlsx
    14.8 KB · Affichages: 9

Jacky67

XLDnaute Barbatruc
Bonjour à Tous quelqu'un pourrait il m'aider

Je souhaite écrire une fonction ou formule qui me compte le nombre de cellule colorié en bleu (FEUIL 1 COLONNE A) et qui prends en compte les dates de la colonne B
EXEMPLE POUR LE MOIS DE JANVIER ; il va me compter le nombre de cellule colorié en bleu et dont les valeurs de la colonne B sont compris entre le 01/01/2022 et le 31/01/2022
ainsi de suite pour le mois de février.

les résultats seront mis dans ma feuil sheet1 (COLONE B)
merci
Bonjour,
Une proposition en pj
La mise à jour se fait à la sélection de la feuille "Sheet1"
 

Pièces jointes

  • Fi V1.xlsm
    27.4 KB · Affichages: 4

AtTheOne

XLDnaute Impliqué
Supporter XLD
Bonjour à toutes & à tous, bonjour @Abdoul aziz , bonjour @Jacky67
Comme toujours j'arrive après la bataille ...

Mais voici une solution avec une fonction et une formule :
J'ai ajouté une liste de choix avec une mise en forme conditionnelle pour les autres couleurs au cas où ...
1647534681319.png

1647534717715.png

La fonction :
Enrichi (BBcode):
Function couleur(Plg As Range) As Variant
Application.Volatile True
     ReDim Tb(1 To Plg.Count, 1 To 1)
     i = 0
     For Each C In Plg.Cells
     i = i + 1
          Tb(i, 1) = C.Interior.Color
     Next C
     couleur = Tb
End Function
La formule (en Sheet1!B2) :
Enrichi (BBcode):
=SOMMEPROD((Feuil1!$B$2:$B$130<>"")*(MOIS(Feuil1!$B$2:$B$130)=MOIS(1&$A2))*(couleur(Feuil1!$B$2:$B$130)=couleur(INDEX($D$2:$D$6;EQUIV($B$1;$D$2:$D$6;0)))))

(J'exclus les ligne pour lesquelles la date n'est pas renseignée)
Voir le classeur en pièce jointe.
Amicalement
Alain
 

Pièces jointes

  • Compter le nombre de cellule colorié selon une critère date.xlsm
    23.9 KB · Affichages: 2

Abdoul aziz

XLDnaute Junior
Bonjour à toutes & à tous, bonjour @Abdoul aziz , bonjour @Jacky67
Comme toujours j'arrive après la bataille ...

Mais voici une solution avec une fonction et une formule :
J'ai ajouté une liste de choix avec une mise en forme conditionnelle pour les autres couleurs au cas où ...
Regarde la pièce jointe 1134053
Regarde la pièce jointe 1134054
La fonction :
Enrichi (BBcode):
Function couleur(Plg As Range) As Variant
Application.Volatile True
     ReDim Tb(1 To Plg.Count, 1 To 1)
     i = 0
     For Each C In Plg.Cells
     i = i + 1
          Tb(i, 1) = C.Interior.Color
     Next C
     couleur = Tb
End Function
La formule (en Sheet1!B2) :
Enrichi (BBcode):
=SOMMEPROD((Feuil1!$B$2:$B$130<>"")*(MOIS(Feuil1!$B$2:$B$130)=MOIS(1&$A2))*(couleur(Feuil1!$B$2:$B$130)=couleur(INDEX($D$2:$D$6;EQUIV($B$1;$D$2:$D$6;0)))))

(J'exclus les ligne pour lesquelles la date n'est pas renseignée)
Voir le classeur en pièce jointe.
Amicalement
Alain
MERCI ça fonctionne
 

Discussions similaires

Réponses
2
Affichages
202

Statistiques des forums

Discussions
302 097
Messages
2 000 364
Membres
214 826
dernier inscrit
Thom34r