Microsoft 365 Compter des cellules Vides

sev31130

XLDnaute Impliqué
Bonjour et Merci par avance

Comme souvent j'essaie de faire ce queje sais faire et je vous demande de m'aider pour finir
j'ai un tableau avec des colonnes que je rempli chaque jour, et il y a des calculs que je ne sais pas faire
et des questions que je pose concernant l'insertion de ligne sur un petit fichier ci joint

Si par bonté vous pouviez régler tout ou partie de mes questions je vous en remercie par avance

Cordialement
 

Pièces jointes

  • GENERAL.xlsx
    15.5 KB · Affichages: 6

sev31130

XLDnaute Impliqué
bonsoir

ok suis navré
voici mes questions

1comment calculer par colonne
ligne F4:W4 le nbre de cellule vide après le dernier 1
ligne F5:W5 le nbre de cellule vide après le dernier 0 ou 1
2comment inserer ligne par ligne en ligne 11
et à la demande, sans passer par la fonction insérer merci
3en colonne 10 comment avoir toujours le 1 en ligne 11
tout en insérant des lignes tous les jours
 

Staple1600

XLDnaute Barbatruc
Bonsoir

Pas vu de cellules vides dans les plages de cellules F4:W5

Sinon avec ce que j'ai compris pour le 3)
(*) macro à affecter à un bouton par exemple
VB:
Sub Insert_Onze()
Rows(11).Insert Shift:=-4121, CopyOrigin:=1: Range("B11:W11").Borders.Value = 1: [O11] = 1: [A11] = Date: [X11] = "=SUM(RC[-18]:RC[-1])+1"
End Sub

(*) voir ici pour le tutoriel
 

sev31130

XLDnaute Impliqué
Pour le 1 je pense que je me suis mal expliqué
il faudrait en F4 compter en colonne F11:F2500 le nombre de cellule vide apres le dernier 1
(dans le cas précis 6) et idem pour toutes les colonnes F:W la formule en ligne 4 de chaque colonne
il faudrait en F5 compter en colonne F11:F2500 le nbre de cell. vide apres le dernier 0 ou 1
dans le cas précis 6) et idem pour toutes les colonnes F:W la formule en ligne 5
merci
comme vous verrez sur le ficher la macro n'est pas ce qu eje pensais
merci

Cordialement
 

Pièces jointes

  • GENERAL2.xlsx
    18.6 KB · Affichages: 3
Dernière édition:

job75

XLDnaute Barbatruc
Bonjour sev31130, JM, le forum,

Formule en F4 à tirer vers la droite :
Code:
=SIERREUR(EQUIV(1;DECALER(F10;1;;NB($A:$A));0)-1;NB($A:$A))
Formule en F5 à tirer vers la droite :
Code:
=MIN(SIERREUR(EQUIV(1;DECALER(F10;1;;NB($A:$A));0)-1;NB($A:$A));SIERREUR(EQUIV(0;DECALER(F10;1;;NB($A:$A));0)-1;NB($A:$A)))
Formule en F7 à tirer vers la droite :
Code:
=SOMME(DECALER(F10;1;;NB($A:$A)))
Formule en F8 à tirer vers la droite :
Code:
=NBVAL(DECALER(F10;1;;NB($A:$A)))
Pour la 3ème question il ne s'agit pas de la colonne 10 mais de la colonne X.
Formule en X11 à tirer vers le bas :
Code:
=DECALER(X11;-1;)+1
La macro du bouton (clic droit pour l'affecter) :
VB:
Sub Nouvelle_ligne()
Application.ScreenUpdating = False
[A11:X11].Copy
[A11].Insert xlDown 'insère les cellules copiées
[A11] = Date
[B11:W11].ClearContents 'RAZ
End Sub
A+
 

Pièces jointes

  • GENERAL(1).xlsm
    23.1 KB · Affichages: 5

sev31130

XLDnaute Impliqué
Bonjour Job75, Stapple le forum

que dire, Merci pour cette gentillesse de me donner l'explication et de me joindre le fichier prêt à l'emploi
la gentillesse des participants bénévoles que vous êtes, mérite le respect et les remerciements les plus sincères

Cordialement

(fermer la discussion sujet traité )
 

job75

XLDnaute Barbatruc
Vous pouvez donc marquer mon post #6 comme solution de cette discussion.

Avant de nous quitter voici une formule plus simple en F5 :
Code:
=SIERREUR(EQUIV(VRAI;DECALER(F10;1;;NB($A:$A))<>"";0)-1;NB($A:$A))
Mais c'est une formule matricielle à valider par Ctrl+Maj+Entrée.
 

Pièces jointes

  • GENERAL(2).xlsm
    23.5 KB · Affichages: 6

Membres actuellement en ligne

Statistiques des forums

Discussions
299 832
Messages
1 979 414
Membres
206 721
dernier inscrit
Sud catering