Comptage cellules

  • Initiateur de la discussion Nico
  • Date de début
N

Nico

Guest
<HTML>Bonjour,

Mon besoin est le suivant :

Dans une colonne d'un tableau, les cellules sont de couleurs différentes.
J'aimerais compter les cellules de couleurs vertes par exemple.
Est ce que cela est possible ?

Merci d'avance

@+</HTML>
 
T

T. Jean-Marie

Guest
<HTML>Bonjour,

Je te propose ma solution, par une fonction macro excel 4 :

Inserer une feuille macro excel 4, en cliquant avec le bouton de droit de la souris sur un des onglets de changement de feuille. Un menu apparaît, clique sur insérer.

1) Copie le texte de la macro à partir de la cellule A1 (que tu trouvera à la fin de ce message).

2) clique dans le menu "insertion", puis sur "Nom", et sur "Définir".

3) après l'ouverture de la boîte de dialogue, change les paramêtres :
- Donne un nom à cette fonction (en haut)
- Dans "catégorie", choisi "personnalisé"
- clique sur le bouton radio "Fonction"
- et sur OK

4) retourne dans ta feuille où tu comptabiliser les cellules coloriées

5) dans la cellule mais la couleur à calculer

6) insert dans cette cellule, une fonction, clique sur la catégorie "personnalisé" dans la boîte de dialogue, et sur le nom de la fonction, que tu lui avait donné, et sur "OK"

7) une boîte de dialogue, apparaît :
Dans plage, selectionne la plage des cellules coloriées (elle peur être externe à la feuille)
Dans couleur, tape la référence de la cellule de la couleur à calculer.
Clique sur OK

Voilà, je m'excuse de la longueur des expliquations, mais l'utilisation des macros excel 4, étant tombé dans l'oubli.

Dans la macro, l'argument 63 de la fonction lire.cellule renvoi la couleur de fond de la cellule. L'argument 64, renvoi la couleur des caractères de la cellule.

Bonne journée.
A+ Jean-Marie

Ci-dessous le texte de la macro

=ARGUMENT("Plage";8)
=ARGUMENT("Couleur";8)
=POSER.VALEUR(B1;0)
=LIRE.CELLULE(63;Couleur)

=POUR("I";1;COLONNES(Plage))

=POUR("J";1;LIGNES(Plage))

=SI(LIRE.CELLULE(63;INDEX(Plage;J;I))=A4;POSER.VALEUR(B1;B1+1);"")

=SUIVANT()
=SUIVANT()

=RETOUR(B1)</HTML>
 

Discussions similaires

  • Question
XL pour MAC MFC
Réponses
5
Affichages
495

Statistiques des forums

Discussions
303 442
Messages
2 011 229
Membres
218 924
dernier inscrit
KED97