Comment tronquer du texte dans une colonne ?

Siwel

XLDnaute Nouveau
Bonjour a tous!

Je dois a l'aide de codes permanents (codes regroupant des lettres et des chiffres) prendre seulement une partie de ce code et ensuite y rajouter des valeurs pour pouvoir ensuite, si tout ce passe bien, calculer des moyennes.

Voici un exemple:

Liste Originale Liste Tronquee Liste remanipulee
GREM12547801 78 1978
FRTM34755806 58 1958
POLG12128012 80 1980
GHRT01070223 02 2002
...etc... ... ...

Comme vous pouvez voir, jèssaie de tronquer 8 caracteres au debut du texte, et 2 caracteres a la fin du texte. Ensuite, je voudrais rajouter au chiffre (en faisant une addition) 1900 si le nombre est superieur a 20 ou 2000 si le nombre est inferieur a 20.

Excel devrais avoir une facon de tronquer des caracteres avant et apres, et il devrait egalement etre capable de convertir du 'texte' en 'chiffres' (en termes de proprietes).

Merci a l'avance, je suis sur qu'un cracke est parmis ce forum et qu'il va pouvoir repondre a mon probleme.
 

Tibo

XLDnaute Barbatruc
Salut Siwel,

Tu peux essayer ceci :

si ta référénce est en A1 :

=ANNEE(DATE(DROITE(A1;2);1;1)) (colonne à mettre au format date 'aaaa'

autre solution :

=SI(CNUM(DROITE(A1;2))<=20;DROITE(A1;2)+2000;DROITE(A1;2)+1900)

@+
 

dg62

XLDnaute Barbatruc
Bonsoir Siwel, le forum


Code:
=CNUM(DROITE(GAUCHE(A1;10);2))

et le code ci-dessus peut-être avantageusement remplacé par celui de Monique

Code:
=STXT(A1;9;2)*1

en A1 le code sur 12 caractères


et la formule complète avec le test

Code:
=SI(CNUM(DROITE(GAUCHE(A1;10);2))<20;CNUM(DROITE(GAUCHE(A1;10);2)+2000);CNUM(DROITE(GAUCHE(A1;10);2)+1900))

Message édité par: dg62, à: 30/08/2005 18:59
 

Monique

Nous a quitté
Repose en paix
Bonjour,

J'avais en colonne A la liste originale + tronquée + manipulée ! (Tibo aussi, j'ai l'impression)

En B2 :
=STXT(A2;9;2)*1
(*1 pour rendre le résultat numérique)
Format nombre : 00

En C2 (pas de changement) :
=B2+1900+SI(B2<20;100)

Direct sans passer par la colonne B :
=STXT(A2;9;2)+1900+SI(STXT(A2;9;2)*1<20;100)
 
S

Siwel

Guest
Heu, merci beaucoup a tous!

Mais je ne comprend pas grand choses de ce que vous me dites.

Imaginez que j'ai une liste d'environ 700 entrée maintenant.

C'est pour ca que je voudrais tronquer les 8 premiers caracteres et les 2 derniers. Ensuite, avec une simple verification de conditions, je pourrais ajouter 1900 ou 2000.

Je ne suis pas sur de comprendre tout ce que vous me dites, je ne suis vraiment pas expert en matiere Excel...

Merci!

J'essaierai quelques codes que vous m'avez dit, mais je ne sait meme pas ou les mettres...

Je pensait plutot a une facon d'editer les proprietes des cellules en utilisant les codes de format nombre...

Ou encore utiliser une fonction similaire a 'tronquer des zéros' avec les nombres ou quelquechose comme ca.

Enfin, merci encore, mais, je vais essayer de mon mieux de comprendre vos solutions.
 
S

Siwel

Guest
WOOOOOOWWWOWWOWW!!!

Merci monique!

J'ai compris ton message et tu viens de me faire economiser environ 3 heures de copier coller backspace etc...!!!

Merci a tous!!!

Chu tout content et je saute dans les airs en me claquant les talons!
 

Discussions similaires

Statistiques des forums

Discussions
299 703
Messages
1 978 594
Membres
206 300
dernier inscrit
gauthier75011