Calcul trop long avec sommeprod

  • Initiateur de la discussion Jacques
  • Date de début
J

Jacques

Guest
Bonjour à tous,

J'aurai besoin d'âme(s) charitable(s) pour m'aider sur mon fichier joint.
Le but de ce fichier est de visualiser par période (semaine) la somme de différents défauts sur 1, 2 ou 3 machines (choisies à la l'aide des case à cocher en haut à gauche de l'onglet suivi valves)
La saisie se faisant dans l'onglet valves finies. Jusque là tout va bien, 25 lignes pas de problème.
Quand j'augmente le nombre de ligne, tout ce complique, le calcul est très, très long (1200 lignes voir le double)
Est ce que quelqu'un peut me dire s'il y a possibilité de modifier ce fichier pour que le temps de calcul reste correct?

Merci à tous de l'attention que vous porterez à ma demande.

Jacques

pour info je tourne sous EXCEL 2000 [file name=tab_sommeprod_20050825185903.zip size=29339]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/tab_sommeprod_20050825185903.zip[/file]
 

Pièces jointes

  • tab_sommeprod_20050825185903.zip
    28.7 KB · Affichages: 33

Ti_

Nous a quitté
Repose en paix
Tu peux déjà commencer par réduire la taille de tes formules, en les simplifiant un peu :

(en B5)
=SOMMEPROD(($A5='Valves finies'!$T$4:$T$28)*(($A$1='Valves finies'!$A$4:$A$28)+($A$2='Valves finies'!$A$4:$A$28)+($A$3='Valves finies'!$A$4:$A$28))*'Valves finies'!F$4:F$28)

sur 1200 lignes, le gain devrait être appréciable même si avec des matrices il faut toujours patienter un peu.
 

Ti_

Nous a quitté
Repose en paix
une autre solution qui utilise une feuille intermédiaire. Ca prend plus de place, mais ça devrait aller plus vite puisqu'on n'a plus de SOMMEPROD mais que des SOMME.SI. [file name=SommeSi_20050825211354.zip size=32103]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/SommeSi_20050825211354.zip[/file]
 

Pièces jointes

  • SommeSi_20050825211354.zip
    31.4 KB · Affichages: 71
J

Jacques

Guest
Merci encore, j'étais entrain de regarder un truc dans le genre mais j'étais loin de ce que tu as et pour ça je te remerci encore.

Merci à tout ceux qui prenne du temps pour nous faire avancer.

Jacques
 

Statistiques des forums

Discussions
299 951
Messages
1 980 334
Membres
207 058
dernier inscrit
Defroise