1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Supprimer ou faire disparaitre 0 ou #DIV/0!

Discussion dans 'Forum Excel' démarrée par Guido, 21 Juillet 2008.

  1. Guido

    Guido XLDnaute Accro

    Messages :
    1151
    Habite à:
    Geneve
    Utilise:
    Excel 2003 (PC)
    Bonsoir le forum

    J'aimerais supprimer ou faire disparaitre le 0 ou #DIV/0!

    qui se trouvent dans des cellules merci de votre aide

    Guido
     

    Pièces jointes:

  2. ya_v_ka

    ya_v_ka XLDnaute Impliqué

    Messages :
    762
    Habite à:
    Courtemaîche
    Utilise:
    Excel 2013 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Salut

    avec un SI()

    SI(taformule=0;"";taformule)
    SI(ESTERREUR(taformule);"";taformule)

    ou combiné SI(OU(ESTERREUR(taformule);taformule=0);"";taformule)

    Ya'v
     
    Dernière édition: 21 Juillet 2008
  3. Denis132

    Denis132 XLDnaute Impliqué

    Messages :
    784
    Habite à:
    Valleyfield
    Utilise:
    Excel 2010 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonsoir Guido, ya_v_ka,

    Probablement que tu devras changer la formule d'où proviennent ces valeurs car dans le fichier que tu nous as laissé, il n'y a pas de formules, que des chiffres et des #DIV/0!. Pas évident. Les solutions de ya_v_ka devraient te servir dans ton autre fichier.

    @+

    Denis
     
  4. Pyrof

    Pyrof XLDnaute Occasionnel

    Messages :
    361
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonjour,

    Pour supprimer l'affichage de 0 outils option affichage décocher afficher valeur 0

    Pour éviter le message DIV/0, j'utilise la fonction :

    Function div(a, b)
    Application.Volatile
    If a*b = 0 Then
    div = ""
    Else
    div = a / b
    End If
    End Function
     
  5. Guido

    Guido XLDnaute Accro

    Messages :
    1151
    Habite à:
    Geneve
    Utilise:
    Excel 2003 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonsoir le forum

    Merci pour les reponses,je vais tester

    A plus

    Guido
     
  6. Franziskaner

    Franziskaner XLDnaute Junior

    Messages :
    65
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonsoir,

    Dans un esprit de simplification, pour ne pas avoir à taper de formule concernant le 0 :

    Format de cellule>Nombre>Personnalisé

    et indiquer 0;; comme format
     
  7. Guido

    Guido XLDnaute Accro

    Messages :
    1151
    Habite à:
    Geneve
    Utilise:
    Excel 2003 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonjour

    Merci pour ses infos

    Guido
     
  8. ericcool

    ericcool XLDnaute Nouveau

    Messages :
    12
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    tBonjour,
    En cherchant un correctif à #DIV/0! sur le forum, je suis arrivé jusqu'à ce post qui m'a bien aidé (ESTERREUR). J'aurais une tite question concernant le message de Pyrof qui utilise une fonction pour éviter le désagrément. Comment utilise t'on une fonction dans ce genre de situation ? On la place, je suppose dans un module mais comment l'applique t'on à une ou des cases qui contiennent une formule qui affiche #DIV/0 ???? Je ne comprend pas trop les fonctions.
    Merci de votre participation & bonne fin de nuit

    Ericcool
     
    Dernière édition: 10 Décembre 2014
  9. ericcool

    ericcool XLDnaute Nouveau

    Messages :
    12
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Re le forum

    Un petit Up pour l'après midi au cas où l'un de vous auriez un petit "tuto" à mettre en ligne.
    Merci & à bientôt de vous lire
    Ericcool
     
  10. chris

    chris XLDnaute Barbatruc

    Messages :
    9169
    Habite à:
    près de Saint Quentin en Yvelines
    Utilise:
    Excel 2010 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bonjour

    Depuis la version 2007 : =SIERREUR(formule qui risque de renvoyer l'erreur;0)

    exemple =SIERREUR(B12/A12;0) (A12=0 donc erreur)
     
  11. natorp

    natorp XLDnaute Accro

    Messages :
    1407
    Utilise:
    Excel 2013 (PC)
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    Bjr eric

    tu fais un copier/coller de la fonction dans un nouveau module.
    et tu écris "=div(A1;A2)" dans la cellule concernée par la division de A1 par A2

    cordialement, Gérard
     
  12. ericcool

    ericcool XLDnaute Nouveau

    Messages :
    12
    Re : Supprimer ou faire disparaitre 0 ou #DIV/0!

    bonsoir chris, bonsoir natorp

    Merci chris pour cette mise à jour. Merci natorp pour ton avancée. Donc si je comprends bien, je ne peux utiliser cette fonction que sur la cellule, résultat de la division ? . Le problème est : si cette cellule contient une formule, la fonction est sans objet ?
    Je viens de rentrer et regarderai de plus dans la soirée.
    Merci à vous.
    P.S : Post apprécié vu le nombre de "lectures"
    Ericcool
     
    Dernière édition: 10 Décembre 2014

Partager cette page